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Sesi 1 : Basic Motion Flash (3 Motion) 

 
1. Pendahuluan 
Modul sesi 1 akan menjelaskan bagaimana cara Flash membuat sebuah animasi, yaitu ada 4 cara 
(Frame by frame, Motion Tween, Motion Shape dan Script). Modul ini dimulai dari pembuatan 
objek sampai dengan pembuatan pergerakannya. Objek yang digunakan masih menggunakan 
objek primitif (lingkaran dan bintang). Hasilnya berupa file format gambar dengan ekstensi .GIF 
dan .JPG yang ditampilkan menggunakan picture viewer. 
 

 
 

2. Persiapan 
Persiapan bidang kerja / Stage : 
1. Jalankan Macromedia Flash, di kotak dialog pilih Flash Document. 
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2. Klik kanan area kosong stage → Document Properties... 
3. Atur ukuran bidang kerja 800 X 600 pixel, 10 FPS dan Background color warna hitam. 
 

  
 

4. Klik 2x toolbar Insert Layer  
untuk menambahkan 2 buah layer baru di 
timeline Flash. 

 
 

 
 
 

5. Doble klik pada layer name untuk 
mengganti nama masing-masing 
layer. 
 
Ganti namanya menjadi 
 Motion Shape 
 Motion Tween 
 Frame by Frame 
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3. Membuat Objek (1) 
 

1. Klik frame 1 layer 
“Frame by Frame”. 
Tekan keyboard Ctrl + 2 
(center canvas). 
 

 

2. Klik Oval Tool . 
 
 

3. Hilangkan warna  

Stroke color  
 (garis tepi) ④ dengan 
memilih tanda silang 
diagonal. 

Fill color  
(isi lingkaran) diisi 
dengan warna abu-abu. 
 

5. Sambil menahan tombol 
SHIFT, buat sebuah 
lingkaran seperti pada 
gambar. 

 

4. Animasi (1) 
 

 

1. Klik kanan frame 12 layer “Frame by Frame” → ② 
klik Insert Keyframe. 

3. Buat 4 keyframe lagi pada frame 24, 36, 48 dan 60. 
  

 
 

4. Klik Selection Tool (V)   → lalu klik frame 12 layer “Frame by Frame”→ klik objek lingkaran. 
 

 

5. Pindahkan objek lingkaran sesuai dengan gambar. 
 

 

  

6. Lalu pindahkan 
objek lingkaran 
yang ada di frame 
24, 36, 48, dan 60 
sesuai gambar 
berikut ini.  

Klik terlebih dahulu nomor framenya baru kemudian pindahkan objek lingkaran. 
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Membuat Objek dan Animasi (Motion Tween) 
 

1. Klik frame 1 layer “Motion 
Tween”. 
Tekan keyboard Ctrl + 2 (center 
canvas) 
 

 

2. Klik Oval Tool . 
 
 

3. Hilangkan warna  

Stroke color  
(garis tepi) dengan memilih 
tanda silang diagonal. 

Fill color  
(isi lingkaran) ④ diisi dengan 
warna merah 
 

5. Tahan tombol shift → buat 
objek lingkaran seperti pada 
gambar 
 
Tombol Shift digunakan agar lingkaran 
bisa presisi panjang & lebarnya 

  

Jika belum pas gunakan Selection Tool (V) untuk memindahkan letak lingkaran agar sesuai gambar. 
 

6. Klik kanan frame 60 di layer 
“Motion Tween” → klik Insert 
Keyframe 

 
  

7. Klik Selection Tool (V)  → 
klik frame 60 layer “Motion 
Tween” → lalu geser ke kanan 
lingkaran merah yang ada di 
stage (lihat gambar) 

 
  

8. Klik frame 1 → tahan tombol 
Shift → lalu ⑨ klik frame 60. 
⑩ klik kanan pada area yang 
terseleksi → ⑪ klik “Create 
Motion Tween” 

 
  

Kunci layer “Frame by Frame” dan “Motion Tween” 
dengan cara klik titik putih pada layer yang sejajar 
dengan toolbar gembok 
 

Dengan mengaktifkan icon gembok  pada suatu layer  
maka objek-objek yang ada pada layer tersebut otomatis tidak bisa 
dirubah-rubah  
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3. Membuat Objek dan Animasi (Motion Shape) 
 

1. Klik frame 1 layer 
“Motion Shape”. 
Tekan keyboard Ctrl + 2 (center 
canvas) 
 

 

2. Klik Oval Tool . 
 
 

3. Hilangkan warna  

Stroke color  
(garis tepi) dengan memilih 
tanda silang diagonal. 

Fill color   
(isi lingkaran) ④ diisi dengan 
warna biru 
 

5. Letakkan objek lingkaran 
seperti pada gambar 

  

Jika ukurannya belum pas gunakan Free Transform Tool (Q) untuk mengatur ukuran lingkaran agar sesuai gambar. 
 

6. Klik kanan frame 60 di layer 
“Motion Shape” → klik Insert 
Keyframe 

 
7. Hapus objek lingkaran biru di stage dengan cara : 

klik objek lingkaran biru yang ada di stage → tekan keyboard delete. 
 

8. Klik + tahan toolbar Rectagle Tool 
(R) sehingga muncul Polystar Tool. 
Klik Polystar Tool. 
 

 

9. Hilangkan warna  

Stroke color  
(garis tepi) dengan memilih tanda 
silang diagonal. 

Fill color   
(isi lingkaran) diisi dengan warna 
kuning. 
 

10. Buat bentuk bintang dan letakkan 
sesuai dengan gambar. 

  

11. Klik frame 1 → 
tahan tombol 
Shift → lalu 
⑫ klik frame 
60.  



 

6 

6 
 

12. Pilih Tween Shape di panel 
Properties (ada di bawah). 
 
Tekan Ctrl + F3 jika tidak muncul 
panel Properties Tween 

 
 

4. Publish (Export file) 
Proses pembuatan animasi sudah selesai, untuk melihat hasilnya (test movie) dapat menggunakan 
kombinasi keyboard Ctrl + Enter atau klik menu Control → Test Movie. 
 

 
 

Proses yang berikutnya adalah mem-publish animasi menjadi file .GIF yang biasa digunakan untuk iklan-
iklan yang ada di situs internet. 
 

1. Klik File → Publish Setting... (Ctrl + Shift + F12) 
2. Tandai (cek) GIF Image (.gif) di jendela Publish Settings yang muncul. 
3. Masuk ke tab GIF → pilih radio button Animated → OK. 
 

  
 

4. Klik File → Publish Preview → Default-(GIF)    F12. 
 

5. Simpan 
1. Klik File → Save As... (Ctrl + Shift + S) 
2. Akses My Documents kemudian buat sebuah 

folder baru → beri nama folder tersebut 
dengan NPM-NamaMahasiswa 

 
  

3. Masuk ke folder tersebut  
(My Documents/NPM-NamaMahasiswa) 

4. Simpan file dengan nama 3 Basic Motion → 
Save 
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Lanjutan Sesi 1 : Basic Motion Flash (Action Script) 

 
1. Pendahuluan 
Sebuah tutorial yang diadopsi dari www.bengkelflash.com akan menjelaskan 
contoh pembuatan animasi fantastis menggunakan pemrograman flash 
(Action Script). Komponen pembuatnya sangat sederhana sekali, hanya berisi 
sebuah objek (bar batang) dan 2 buah script flash yang digunakan untuk 
menggerakkan bar batang tersebut. Meskipun sederhana tetapi hasil akhir 
animasi akan terlihat fantastis. Silahkan dilanjut... 

 
 

2. Persiapan Stage dan Objek 
1. Buat sebuah file baru Flash  

File → New (Ctrl +N) 
2. Klik menu Modify → Document (Ctrl + J) 
3. Atur ukuran bidang kerja 550 X 400 px → 

background color : hitam → Frame rate : 15 
fps → OK  

  

4. Klik frame 1 “Layer 1” 

 
  

5. Klik Rectangle Tool   
stroke color = (kosong) 
fill color = semi-hijau 

 
→ lalu buat kotak di stage 
 

 

http://www.bengkelflash.com/
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6. Klik Selection Tool → klik kotak semi-
hijau → pada panel properties di bagian 
bawah, atur ukuran kotak menjadi : 

  
  

7. Klik kanan kotak semi-hijau → Convert to 

Symbol → atur : 

   Name : semi-hijau 
   Type : Movie Clip 
   Registration point : bawah-tengah 

→ OK  
  

8. Klik kotak semi-hijau 
9. Pada Properties Movie Clip, ganti <Instance 

Name> menjadi “bar” (tanpa tanda petik) 

 
  

3. Menggerakkan Objek lewat Action Script 
1. Klik kotak semi-hijau 
2. Klik menu Window → Actions (F9) 

pada jendela Actions yang muncul ketikkan 
syntax sesuai gambar samping 
 

 
  

3. Klik Check Syntax  untuk mengecek apakah 
ada error pada script yang ditulis. 
 

4. Kalau sudah benar tutup jendela Actions dengan 
cara mengklik judul bar actions 

 

  

  

5. Klik Frame 1 “Layer 1” →klik menu Window → Actions (F9) 
ketikkan syntax sesuai gambar di bawah 
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6. Klik Check Syntax  untuk mengecek apakah 
ada error pada script yang ditulis. 
 

Jika masih ada error cek ulang syntax yang sudah ditulis. 

7. Tutup jendela Actions 
8. Klik menu Window → Test Movie (Ctrl + Enter)  

  

4. Simpan 
1. Klik File → Save As (Ctrl+Shift+S) 

simpan di folder masing-masing yang ada di  
“My Document\NPM-NamaMahasiswa” 

2. Lalu simpan dengan nama “animasi fantastis” → 
Save 

 
  

5. Tugas Lab Sesi 1 
1. Buat sebuah project baru flash (File → New) dengan ukuran 550 x 400 pixel 
2. Buat sebuah gambar langit malam menggunakan flash lengkap dengan bintang dan bulan. 

Desain bebas, minimal berisi 5 buah bintang dan sebuah bulan. 
 

  
 
 
 
 

Contoh file ada di My 
Document/Aset Flash/Night 
Sky.jpg 

 
 
 
 
 
 
 

3. Setelah selesai simpan (File → Save As) ke folder masing-masing di My Documents/NPM-
NamaMahasiswa, simpan dengan nama : Night Sky → Save 
 

 
 

4. Export “Night Sky” yang sudah jadi menjadi file Joint Photographic Experts Group (.JPEG) 
dengan cara klik menu File → Export → Export Image...  

5. Simpan di masing-masing folder (My Documents/NPM-NamaMahasiswa) dengan nama 
“Night Sky” → Save as type: JPEG Image (*.jpg) → Save 
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Sesi 2 : Rotasi Bulan 
 

1. Pendahuluan 
Pembuatan simulasi rotasi bulan menggunakan flash akan dijelaskan pada pertemuan ini.  Komponen 
penyusunnya terdiri dari peng-import-an gambar (.JPG), memasukkan text, memberi efek sederhana ke 
objek, warna gradasi, motion tween dan layer guide (jalur). Rotasi bulan memunculkan objek bulan yang 
berkeliling mengelilingi objek bumi sesuai dengan alur (orbit) yang sudah ditentukan pada layer guide, 
background berasal dari gambar .JPG yang sudah disediakan. Hasil akhir animasinya berupa file dengan 
ekstensi .exe yang bisa dijalankan di sistem operasi windows. 
 

 
 

2. Persiapan 
Persiapan bidang kerja / Stage : 
 

1. Buat area kerja baru flash, klik File → New 
(Ctrl+N) 
 

2. Klik kanan stage yang berwarna putih → 
Document properties 

 
3. Atur ukuran bidang kerja 800 X 600 pixel,  

→ Background color hitam → 10 FPS 
  
  

4. Tambahkan 3 buah layer baru dengan cara klik 

Insert Layer sebanyak 3x. 
 

5. Klik cepat 2x layer name → ganti nama 
masing-masing layer seperti gambar di 
samping (urut dari atas). 
Teks, Bulan, Bumi, Background 
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3. Membuat Objek (Bumi) 
1. Klik frame 1 layer “Bumi”. 

Tekan keyboard Ctrl + 2 (center canvas). 
 

 

2. Klik Oval Tool . 
 
 

3. Hilangkan warna  

Stroke color  
 (garis tepi) dengan memilih tanda silang 
diagonal. 

Fill color  
(isi lingkaran) diisi ④ dengan warna gradasi 
biru ke hitam. 
 

5. Tahan tombol SHIFT lalu buat sebuah 
lingkaran seperti pada gambar 

  

6. Klik Selection Tool   
→ klik lingkaran biru yang barusan dibuat 

7. Lihat properties shape yang ada dibawah, 
ubah nilainya menjadi  
W:60, H:60, X:370, Y:270  

  

8. Klik Gradient Transform Tool (F)  → 
letakkan kursor mouser ke tengah lingkaran → 
geser ke sudut kiri atas pusat warna 
gradasinya 

 
  

9. Klik Selection Tool  → klik kanan objek 
lingkaran → Convert to Symbol 

10. Ubah menjadi  
Name : Bumi, Type : Movie Clip → OK  

  

11. Klik tab Filters (ada di bagian bawah samping 
tab properties) 

 
 

12. Tambahkan efek Glow (berpijar) 

Klik Add filters  → Glow → Quality : High 
→ Color : Biru 

 
  

13. Tambahkan efek Blur (kabur) 

Klik Add filters  → Blur → Quality : High 
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14. Tambahkan efek timbul 

Klik Add filters  → Bevel → Quality : High 

 
 

3. Membuat Objek (Bulan) 
 

1. Klik frame 1 layer “Bulan”. 
Tekan keyboard Ctrl + 2 (center canvas). 

 

2. Klik Oval Tool . 
 

3. Hilangkan warna garis tepi 

Stroke color   

Fill color `  gradasi putih ke hitam. 
 

4. Sambil menahan tombol SHIFT, buat sebuah 
lingkaran di stage 

  

5. Klik Selection Tool → klik objek lingkaran abu2 

di stage → atur ukurannya menjadi  
W:37, H:37, X:23, Y:275 

 
 

 

6. Klik Gradient Transform Tool (F)  → klik 2x 
warna putih pada panel Color Mixer → ganti 
warnanya menjadi kuning 

 
  

7. Klik Selection Tool  → klik kanan objek 
Bulan → Convert to Symbol 
Name : Bulan, Type : Movie Clip → OK 

 
  

8. Klik tab Filters 
(ada di bagian bawah – samping tab properties) 

 
 

9. Klik Add filters  → Glow 
→ Blur X : 30 → Blur Y : 30 → Quality : High → 
Color : Kuning 
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3. Membuat Objek (Orbit) 
1. Klik kanan layer bulan → Add Motion 

Guide 

 
muncul layer baru di atas layer bulan 

→ Ganti nama layer  
“Guide: Bulan” menjadi “Orbit” 

 

 

2. Klik Oval Tool . 

3. Stroke color warna putih 
Fill color tanpa warna   

  

4. Klik frame 1 Layer Orbit 
5. Buat bentuk elips (lonjong) di stage 

(dimulai dari sudut atas objek bulan lalu 
drag ke kanan bawah secara diagonal) 

 
  

6. Klik Selection Tool  → klik garis 
lonjong putih barusan 

7. Atur ukuran menjadi W:715, H:220, 
X:42.0, Y:189 

 
  

8. Klik Zoom Tool  → lalu zoom area 
yang berdekatan dengan objek bulan 

 
  

9. Klik toolbar gembok di bagian atas 
sendiri → lalu klik icon gembok di layer 
Orbit 

 
  

10. Klik Eraser Tool (E)  → lalu hapus 
garis putih yang ada di dalam kotak 
merah pada gambar di samping 
 

11. Klik 2x icon gembok di atas sendiri, 
sehingga icon 
gembok hilang 
di semua layer  
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3. Membuat Objek (Background) 
1. Klik frame 1 layer Background 
2. Klik File → Import → Import to Stage... 

(Ctrl + R) 
akses ke My Documents/Aset Flash → 
klik “BG Rotasi Bulan.JPG” → Open 

3. Tekan keyboard Ctrl+2 (Center Canvas) 
4. Klik gambar yang barusan dimasukkan 
5. Lalu atur ukurannya menjadi W:1219, 

H:914, X:-14, Y:-10  
  

3. Membuat Objek (Text) 
1. Klik titik putih layer Background yang 

sejajar dengan icon mata 
 
Untuk membuat agar objek-objek pada layer 
tertentu tidak terlihat di stage klik titik putih 
yang sejajar dengan icon mata 

 
  

2. Klik frame 1 layer Text 
Klik Text Tool (T) → atur 
Tipe Font : Tahoma →  size 24 →  Static 
Text →  warna : putih → Anti-alias for 
readability  
  

3. Klik di sudut kiri atas stage, 
tulis seperti gambar di samping 

4. Seleksi teks “perputaran bulan 
mengelilingi bumi selama 30 hari.” 
ganti ukurannya menjadi 12 → Enter 

 

 

  

5. Klik Selection Tool  
6. Klik Teks barusan → atur ukuran 

menjadi : 

 
 

7. Masuk ke menu Filters → tambahkan 
efek Glow → Quality : High → warna : 
Putih 
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4. Membuat Animasi 
 

1. Klik icon mata paling atas → klik layer 
Background → lalu klik (hilangkan) 
tanda silang di layer Background 
 

2. Klik kanan frame 1 layer Background 
→ Create Motion Tween 

 

 

 
  

3. Klik kanan frame 20 layer Background 
→ Insert Keyframe → klik gambar 
planet di stage → atur ukurannya 
menjadi X:-9, Y:-127 

 
  

4. Klik kanan frame 45 layer Background 
→ Insert Keyframe → klik gambar 
planet di stage → atur ukurannya 
menjadi X:-9, Y:-293 

 
  

5. Klik kanan frame 70 layer Background 
→ Insert Keyframe → klik gambar 
planet di stage → atur ukurannya 
menjadi X:-256, Y:-308 

 
  

6. Klik kanan frame 90 layer Background 
→ Insert Keyframe → klik gambar 
planet di stage → atur ukurannya 
menjadi X:-329, Y:-110 

 
  

7. Klik kanan frame 100 layer 
“Background” → Insert Keyframe → 
klik gambar planet di stage → atur 
ukurannya menjadi X:-14, Y:-10 

 
  

8. Klik frame 100 layer “Bumi” → tahan 
tombol SHIFT → klik frame 100 layer 
“Teks” → klik kanan pada area yang 
terseleksi → Insert Frame 
 

9. Klik icon mata 2x 
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10. Klik kanan frame 1 layer “Bulan” → 
Create Motion Tween 

11. Klik kanan frame 100 layer “Bulan” → 
Insert Keyframe 

12. Klik Zoom Tool (M/Z)  → zoom 
objek bulan yang ada di stage  

  

13. Klik selection tool   → Klik frame 
100 layer “Bulan” → lalu pindahkan 
objek bulan ke ujung garis orbit yang 
ada di bawah (lihat gambar) 
 
jika bulan sudah berada di ujung garis orbit 
bagian bawah, maka biarkan saja (tidak perlu 
digeser

2 
lagi) 

 
Frame 100 layer “Bulan”, Bulan berada di 
bawah garis orbit 

 
  

14. Klik frame 1 layer “Bulan” → lalu 
pindahkan objek bulan ke ujung garis 
orbit yang ada di atas (lihat gambar). 
 
jika bulan sudah berada di ujung garis orbit 
bagian atas, maka biarkan saja (tidak perlu 
digeser

2 
lagi) 

 
Frame 1 layer “Bulan”, bulan berada di atas 
garis orbit 

 
  

15. Pembuatan animasi sudah selesai, Ctrl+Enter atau klik Control → Test Movie untuk melihat 
hasilnya. 

 

5. Publish (Export File) 
Bagian ini memberikan cara untuk meng-export file hasil animasi menjadi file eksecutable (.exe), 
sehingga animasi bisa di-share ke tempat lain tanpa harus memberikan file flashnya (.fla). 

1. Simpan terlebih dahulu file ke komputer, klik File → Save (Ctrl+S) 
2. Akses ke My Documents/NPM-NamaMahasiswa → lalu beri nama “Rotasi Bulan” → Save 

 
3. Klik File → Publish Settings 
4. Pada pilihan cek box, tandai (√) hanya di bagian “Windows Projector (.exe)” 

→ klik Publish → OK 
 

5. Buka Windows Explorer → akses My Documents/NPM-NamaMahasiswa → Rotasi Bulan.exe 
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6. Tugas 
 
Membuat sebuah Peta Jalur Kereta Api dengan kereta yang bergerak didalamnya. 

 Buka project baru flash atur ukuran stage 1000 x 370 pixel, 10 fps 
 Buat sebuah desain Peta Jalur Kereta Api 
 Buat sebuah kereta api (bentuk bebas) kemudian gerakkan pada peta menyesuaikan jalur/guide 
 Jalur kereta minimal ada 4 belokan, bentuk track bebas 

 

 
 

Contoh file ada di My Documents/Aset Flash/Railway.swf 
 

 
 

  

Prioritaskan terlebih dahulu untuk membuat kereta kemudian gerakkan pada track (guide) yang sudah dibuat. Setelah sukses 
membuat motion guide kereta baru kerjakan background/kelengkapan

2 
lain yang ada pada sebuah peta kereta api. 

  
 Setelah selesai simpan (File → Save As) ke folder masing-masing (My Documents/NPM-

NamaMahasiswa) dengan nama Central Java Railway. 
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Sesi 3 : Equalizer Bar 
 

1. Pendahuluan 
Pada player audio biasanya akan muncul gambar visual nada (wave berbentuk batang atau lainya) dari 
musik atau lagu yang sedang dimainkan, lebih familier disebut dengan equalizer. Modul ini berisi contoh 
pembuatan equalizer yang dianimasikan menggunakan script flash, selain itu juga akan didemokan 
bagaimana menambah sebuah file suara Microsoft Wave Sound (WAV) sebagai musik pengiring. Modul ini 
tidak mendemokan equalizer yang diatur agar bisa menyesuaikan dengan suatu suara/lagu. 

 
2. Persiapan Stage 

1. Buat halaman baru flash 
2. Atur ukuran halaman menjadi 320 X2400 px 

→ background putih → Frame rate : 10 FPS → 
OK 

 
  

3. Tambahkan 2 buah layer baru lalu 
Ganti nama “Layer 1” menjadi “Background” 
Ganti nama “Layer 2” menjadi “Bar” 
Ganti nama “Layer 3” menjadi “BackSound” 

 
  

3. Membuat objek (Background) 
1. Klik frame 1 layer Background 

2. Klik Rectangle Tool (R)  →  
stroke color = kosong 
fill color = hitam 

 
→ lalu buat kotak di stage 

3. Klik Selection Tool (V)  → klik kotak 
hitam, atur ukuran menjadi 

 

 

  

4. Klik kanan frame 50 layer Background → 
Insert Frame 

5. Aktifkan kunci (gembok) pada layer 
Background 
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4. Membuat objek (Bar) 
1. Klik frame 1 layer Bar 

2. Klik Rectangle Tool (R)  →  
stroke color = kosong 
fill color = kuning 

 
→ lalu buat batang di stage 

3. Klik Selection Tool (V)  → klik batang 
kuning, atur ukuran menjadi 

 
 

  

4. Klik kanan batang kuning → Convert to 
Symbol (F8), atur : 

   Name : Bar 
   Type : Movie Clip 
   Titik Registration : bawah-tengah 

→ OK 
 

  

5. Klik batang kuning →klik menu Window → Action (F9) → ketikkan script 
 

 
  

Menggandakan objek Bar menjadi 5 bar 
 

6. Tahan Ctrl+Shift → lalu geser ke kanan objek 
batang kuning di stage(bar ke-2) 

7. Tahan Ctrl+Shift → lalu geser ke kanan objek 
batang kuning di stage (bar ke-3) 

 
  

8. Tahan Ctrl+Shift → lalu geser ke kanan objek 
batang kuning di stage (bar ke-4) 

 
  

9. Tahan Ctrl+Shift → lalu geser ke kanan objek 
batang kuning di stage (bar ke-5) 
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Mengubah ukuran ke 4 bar batang baru 
 

10. Klik Selection Tool (V)  → Klik bar ke-2  
→ atur ukuran menjadi : 

 
 

  

11. Klik Selection Tool (V)  → Klik bar ke-3  
→ atur ukuran menjadi : 

  
  

12. Klik Selection Tool (V)  → Klik bar ke-4  
→ atur ukuran menjadi : 

 

 
  

13. Klik Selection Tool (V)  → Klik bar ke-5  
→ atur ukuran menjadi : 

 

 
  

14. Klik Text Tool (T)  → Font Type : Swis721 
BT → warna : merah → align : rata kanan 
lalu buat teks “SOUND FUTURE” di samping 
bar 

 
  

15. Buat lagi teks “OF THE” warna hijau, 
kemudian putar 900 searah jarum jam. 
 

untuk memutar (rotate) objek teks gunakan 
Free Transform Tool (Q) 

 
  

16. Klik kanan frame 50 Layer Bar → Insert Frame 
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5. Meng-import Objek Suara & Simpan 
1. Klik menu File → Import → Import to 

Library... 

 
 
Akses file sound di My Document\Aset 
Flash\thunder-rain.wav → Open 

 
  

2. Klik frame 1 layer BackSound → pada Properties Frame → pilih sound : thunder-rain.wav 
 

 
  

3. Klik kanan frame 50 layer BackSound → Insert Frame 

 
  

4. Silahkan di Test Movie (Ctrl + Enter) 
5. Simpan hasil modul ini ke folder masing2  

(My Documents\NPM-NamaMahasiswa) 
dengan nama file “Equalizer Bar” → Save 
 
Tidak menjadi masalah kalau laboratorium belum 
bisa menyediakan speaker di semua PC-nya, sesuai 
dengan tujuan awal modul ini minimal Anda sudah 
tahu bagaimana cara menambahkan suara pada 
sebuah project flash. 

 

 
6. Tugas Lab 
Buat sebuah dokumen baru flash dengan ukuran stage 500x120 pixel, 10 FPS → simpan (File → Save As) 
tugas ini di folder masing-masing (My Documents/NPM-NamaMahasiswa) dengan nama File “Display 
Player Audio” → Save 
 

 
 

Tugas buat display untuk sebuah player audio, dengan ketentuan : 
 equalizer bar menggunakan action script dengan jumlah batang minimal 15 buah 
 desain player bebas 
 ada nama & NPM animator 
 display waktu/timer lagu (variasi saja, bukan timer yang benar2 menghitung lamanya lagu berjalan) 
 judul lagu + nama band/penyanyi dan tanda mono/stereo 
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Contoh file ada di “My Document/Aset Flash/Display Player Audio.swf” 
 
 

 
 

Contoh Interface Player Audio untuk inspirasi 

 
 

JetAudio Android Audio Player (VLC) 
  

  
Winamp (MMD Skin) AIMP Music Player 

  

 
Iphone Media Player 
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Sesi 4 : Rotasi Bumi 
 

1. Pendahuluan 
 

Pemanfaatan motion shape untuk membuat simulasi rotasi bumi akan dipaparkan pada modul ini. 
Objeknya yaitu bumi dan matahari, keduanya akan mengalami perubahan gradasi warna ketika 
matahari melintas di atas bumi. Inti proses pembuatannya hampir sama dengan modul rotasi 
bulan pada sesi sebelumnya. Tambahan pada rotasi bumi adalah pengenalan motion shape, efek 
rotate (berputar) dan juga implementasi animasi yang dibuat dalam sebuah movie clip. 
 

   
 

2. Persiapan 
Persiapan bidang kerja / Stage : 

 
1. Buat area kerja baru flash, klik File → New 

(Ctrl+N) 
2. Klik kanan stage yang berwarna putih → 

Document properties (Ctrl + J) 
3. Atur ukuran bidang kerja 800 X 600 pixel → 

Background color hitam → 10 FPS → OK 

 
  

4. Klik pengaturan timeline  yang berada di 

kanan atas timeline → Short  
 
Hal ini dilakukan untuk memperkecil jarak antar layer 

 
  

5. Tambahkan 5 buah layer baru dengan cara 
klik Insert Layer sebanyak 5x. 
 

6. Klik cepat 2x layer name → ganti nama 
masing-masing layer menjadi seperti pada 
gambar samping (urut dari atas ke bawah). 
Teks, Matahari, Cahaya Matahari, Bumi, 
Bumi Berpendar, Background 
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3. Membuat Objek (Bumi) 
 

1. Klik frame 1 layer Bumi → klik Oval Tool  

Stroke color (kosong) 
Fill color gradasi biru ke hitam 

 
2.  Buat lingkaran di stage (ukuran bebas) 

3. Klik Selection Tool  → klik objek lingkaran 
barusan → atur ukurannya menjadi  
W:175, H:175, X:312, Y:212 

4. Klik kanan objek lingkaran → copy 
 

5. Klik frame 1 layer Bumi Berpendar → Klik Edit 
→ Paste in Place 

 

 
  

6. Klik titik putih layer bumi yang sejajar dengan 
icon mata  
 

 
 

menghilangkan objek layer bumi pada stage 
 

7. Klik kanan objek lingkaran → Convert to 
Symbol → beri nama “Bumi” → Type : Movie 
clip → OK 

 
 

8. Masuk menu Filters → tambahkan  efek 
Blur → atur ukurannya menjadi “7” → Quality 
High  

  

9. Tambahkan  efek Glow → atur ukurannya 
menjadi “12” → Quality High → warna biru → 
aktifkan fitur Knockout 

10. Klik 2x icon mata paling atas sendiri untuk 
menampilkan semua 
objek yang ada di 
semua layer   

 
3. Membuat Objek (Matahari) 

1. Klik frame 1 layer Matahari 

→ klik Oval Tool  

→ Stroke color warna kuning 
→ Fill color gradasi merah ke hitam 

 
→ Ukuran garis tepi = 10 
→ Tipe garis pilih titik-titik acak  
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2. Tahan tombol SHIFT → buat lingkaran di 
stage (ukuran bebas) 

3. Klik Selection Tool  → klik 2x objek 
lingkaran yang barusan dibuat (sehingga 
terseleksi garis tepi dan dalamnya) → atur 
ukurannya menjadi W:85, H:85, X:25, Y:493 

4. Klik Gradient Transform Tool  → lalu klik 
objek tengah lingkaran yang berwarna merah 

 
 

  

5. Pada tab Color Mixer (sebelah kanan atas) 
→ pindahkan kursor mouse pada titik 
sebelah kiri warna hitam sehingga muncul 
tanda “+” di kursornya 
 

→ klik 2x untuk menambah warna baru 
→ lalu pilih warna kuning 
                                               hasilnya 

 
 

 

 

  

6. Klik Selection Tool  
7. Klik 2x pada objek matahari sehingga 

terseleksi garis tepi dan isinya → klik kanan 
pada area terseleksi → Convert to Symbol 
Name : Matahari → Type : Movie Clip 

 

 

  

8. Klik 2x di Movie Clip Matahari tersebut 
(masuk ke edit Movie Clip Matahari) 

 
tanda sudah masuk ke edit movie clip matahari 

  

9. Klik Insert Layer 1x  
10. ganti nama “Layer 1” menjadi “Matahari” 

dan “Layer 2” menjadi “Cahaya Matahari” 
 

11. Klik Zoom Tool lalu zoom matahari yang 
ada di pojok stage 
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12. Klik garis tepi matahari → klik kanan pada 
garis tepi yang terseleksi tersebut → Cut 

 
  

13. Klik frame 1 layer Cahaya Matahari → Edit → 
Paste in Place 

 
  

14. Klik kanan garis tepi tersebut → Convert to 
Symbol 
Nama   : Lidah Api 
Type     : Movie Clip 

 
  

15. Klik kanan frame 30 layer Matahari → Insert 
Frame 

16. Klik kanan frame 30 layer Cahaya Matahari → 
Insert Keyframe 

 
  

17. Klik kanan frame 1 layer Cahaya Matahari → 
Create Motion Tween 

18. Klik kanan frame 30 layer Cahaya Matahari → 
Create Motion Tween  

  

19. Klik frame 20 layer “Cahaya Matahari” 
20. Lihat properties tween di bagian bawah, 

ganti parameter Rotate : CW, dan masukkan 
angka “15” pada times 
 

Rotate CW (Clock Wise) berputar searah jarum jam, 
15 times = 15 putaran selama animasi berlangsung (dari 
frame 1 s/d 30 Movie Clip Matahari) 

 

  

21. Klik kanan objek (isi) matahari → Copy 
22. Klik layer Matahari 

23. Klik Insert Layer  → ganti nama layer baru 
menjadi “Pendar Matahari” 

  
  

24. Klik frame 1 layer Pendar Matahari 
25. Edit → Paste In Place 
26. Klik kanan objek matahari yang ada di stage 

→ Convert to Symbol 
Nama    : Pendar Matahari 
Type      : Movie Clip 
→ OK 
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27. Masuk menu Filters → tambahkan efek Glow 
→ atur kekuatan Glow menjadi “13” → 
Quality High → warna “Merah” → aktifkan 
“Knockout” 

 
  

28. Klik Selection Tool  atur ukurannya 
menjadi W:55, H:55, X:-27, Y:-27 
 

 

Hasil akhir objek 
matahari 

 

 

  

29. Klik Scene 1 atau tekan Ctrl + E, kembali ke 
stage utama 

30. Tekan keyboard Ctrl+2 (center canvas)  
 

3. Membuat Objek (Cahaya Matahari) 
 

1. Klik frame 1 layer Bumi → Klik kanan objek 
bumi di stage → Copy 
 

2. Klik frame 1 layer Cahaya Matahari → Edit → 
Paste in place 

3. Klik Selection Tool  
 

4. Pada tab Color Mixer (sebelah kanan atas) 
→ klik 2x di warna biru sebelah kiri lalu ganti 
menjadi warna kuning dan Alpha 77% 

 
  

5. Tambahkan palet baru dengan cara klik 2x 
pada area yang hampir di tengah gradasi 
(lihat gambar bawah) → pilih warna kuning → 
Alpha 95% 
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6. Tambahkan palet ke-2 dengan cara klik 2x 
pada area yang juga hampir di tengah gradasi 
(lihat gambar bawah) → masukkan angka hexa 
desimal “#656401” → tekan Enter → lalu 
transparasi Alpha 97% 
 

 

 

  

Warna gradasi cahaya matahari sebelum dan sesudah ditata warnanya 

 
 

3. Membuat Objek (Teks) 
 

1. Klik frame 1 layer Text 

Klik Text Tool (T)  → Text Type : Static Text  
→ Tipe Font : Tahoma →  size 18  
→ warna : putih → align : rata kiri → render 
method : Anti-alias for readability 
 
 

2. Tekan Ctrl+2 (center canvas) 
Klik sudut kiri atas stage  
 
→ tulis seperti gambar di bawah ini 

 

 
 

 
  

3. Seleksi teks “Rotasi Bumi” 
ganti ukuran (font size) menjadi 53 pt 
 

 

 
 

  

4. Klik Selection Tool  → klik teks barusan → 
atur posisi menjadi : 
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3. Membuat Objek (Background) 

1. Klik Selection Tool  
2. Klik frame 1 layer Background 
3. Klik File → Import → Import to Stage (Ctrl + R) 

Masuk ke My Documents/Aset Flash → klik 
“BG Rotasi Bumi.jpg” → Open 

4. Klik kanan gambar background di stage   
→ Convert to Symbol... 
 
 

→ OK 

5. Tekan keyboard Ctrl+2 (Center Canvas)  
  

6. Klik gambar background → atur ukuran 
menjadi W:1666.6, H:918, X:0, Y:0 

7. Klik kanan frame 1 layer Background → Create 
Motion Tween 

  
  

8. Pada Properties Movie Clip 

 
 

Efek Color ganti ke Tint → warna hitam → 68% 
 

 

4. Membuat Animasi 
 

1. Klik kanan frame 45 layer Background → Insert 
Keyframe 

2. Klik gambar background di stage → 
atur ukuran menjadi X:-211, Y:-32 

 
  

3. Pada menu efek Color pilih Tint → warna hitam 
→ 40% 

 
  

4. Klik kanan frame 75 layer Background → Insert 
Keyframe 

5. Klik gambar background di stage → 
atur ukuran menjadi X:-467, Y:-228 

 
  

6. Klik kanan frame 100 layer Background → 
Insert Keyframe 

7. Klik gambar background di stage → 
atur ukuran menjadi X:-390, Y:-265 
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8. Klik kanan frame 150 layer Background → 
Insert Keyframe 

9. Klik gambar background di stage → 
atur ukuran menjadi X:0, Y:0 

 
  

10. Pada menu efek Color pilih Alpha → 14% 

 
  

11. Klik frame 150 layer Bumi Berpendar → tahan 
tombol SHIFT → klik frame 150 layer Teks 

12. Lalu klik kanan pada area yang terseleksi → 
Insert Frame 

 
  

13. Klik kanan frame 75 layer Cahaya Matahari → 
Insert Keyframe 

 
  

14. Klik kanan frame 150 layer Cahaya Matahari → 
Insert Keyframe 

 
  

15. Klik frame 1 layer cahaya matahari  
16. Pada properties tween yang ada di bawah  

Pilih Tween : Shape 

 
  

17. Klik Gradient Transform Tool  →  
klik lingkaran gradasi kuning → geser titik 
pusat cahaya matahari ke kiri bawah 
(sesuaikan dengan gambar samping) 
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 18. Pada tab Color Mixer (sebelah kanan atas) → 

hilangkan 2 warna kuning yang ada di tengah 
sehingga menjadi seperti di bawah ini 

 

 
  

19. klik ganda pada palet kuning ujung kiri → atur 
transparasinya menjadi 10% 

 
  

20. Ubah juga warna hitam yang ada di ujung 
kanan dengan cara klik ganda palet hitam 
ujung kanan → atur transparasinya menjadi 
10% 

 
  

21. Klik frame 75 layer Cahaya Matahari 
22. Pada properties tween yang ada di bawah  

Pilih Tween : Shape 

 
  

23. Klik frame 150 layer Cahaya Matahari 
24. Pada properties tween yang ada di bawah  

Pilih Tween : Shape 

 
  

25. Klik Gradient Transform Tool  → lalu geser 
pusat warna gradasi ke atas kanan (geser 
sesuai dengan posisi pada gambar samping) 
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26. Pada tab Color Mixer (sebelah kanan atas)  
→ hilangkan 2 warna kuning yang ada di tengah 
sehingga menjadi seperti di bawah ini 

 

 
  

 
 
27. Lalu klik ganda pada palet kuning ujung kiri → 

atur transparasinya menjadi 10% 

 
  

 
 

28. Ubah juga warna hitam yang ada di ujung 
kanan dengan cara klik ganda palet hitam 
ujung kanan → atur transparasinya menjadi 
10% 

 
  

 
29. Klik kanan frame 1 layer Matahari → Create 

Motion Tween 

 
  

 
30. Klik kanan frame 150 layer Matahari → Insert 

Keyframe 

 
  

31. Klik Selection Tool  
32. Klik frame 150 layer Matahari → lalu 

pindahkah objek matahari ke pojok kanan atas 
stage 
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5. Simpan 
 

Rotasi bumi selesai dibuat, Ctrl + Enter atau klik Control → Test Movie untuk mem-preview hasilnya. 
Klik File → Save As... (Ctrl + Shift + S) → simpan hasilnya di folder masing-masing yang berada di My 
Documents/NPM-NamaMahasiswa dengan nama file “Rotasi Bumi”. 
 

 
 

6. Tugas 
Motion shape bisa digunakan untuk merubah warna dan merubah bentuk suatu objek, merubah warna 
sudah dipraktekan pada sesi ini sedangkan merubah bentuk akan digunakan sebagai tugasnya. 
Buat sebuah dokumen baru flash dengan ukuran stage 1000 x 400 pixel, 10 FPS → simpan (File → Save As) 
di folder masing-masing (My Documents/NPM-NamaMahasiswa) dengan nama File “Ocean Wave” → Save 
 

 
 

Buat Gelombang Laut di malam hari, dengan ketentuan : 
 Gelombang laut minimal ada 2 gelombang (ombak) 
 Tiap gelombang minimal terdiri dari 3 x perubahan bentuk gelombang  
 Tebing laut, posisi bebas (boleh di samping kanan/kiri stage) 
 Latar langit malam (background langit gunakan warna abu2) + unsur pembentuk langit malam 
 Total frame yang digunakan minimal 100 frame (10 detik animasi) 
 Desain, ukuran & warna dari masing-masing objek secara keseluruhan adalah bebas, sesuaikan saja 

proporsi masing-masing objek dengan gambaran imaginasi yang dipikirkan 
 

Contoh file “My Documents/Aset Flash/Gelombang laut malam.swf” 
 

 
 

Buat terlebih dahulu animasi gelombang lautnya karena tujuan utama tugas ini adalah menerapkan motion  
shape (perubahan bentuk) pada sebuah objek yaitu gelombang laut. Setelah gelombang laut beres, baru  

kemudian mempercantik background/latar pemandangan laut di malam hari. 
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Sesi 5 : Grafik Sinus 
 

Sebuah modul hasil adopsi penuh dari Praktikum Multimedia  
Politeknik Indramayu buatan Munengsih Sari Bunga  

© Politeknik Indramayu 2012 

 
 
1. Pendahuluan 
Grafik (gelombang) sinus adalah fungsi matematika yang berbentuk osilasi (goyangan) halus 
berulang. Cara untuk membuat gelombang sinus akan didemokan pada modul ini dengan 
memanfaatkan fungsi script Math.Object dan duplicateMovieClip. Gelombang Cosinus dan 
Tangen akan dikerjakan sebagai tugas lab pada modul ini. 

 

 
2. Persiapan Halaman (Stage) 

1. Buat halaman baru flash 
2. Atur ukuran halaman menjadi 550 X 400 px → 

background putih → Frame rate : 10 FPS → 
OK 

 
  

3. Klik Insert Layer 2x, lalu 
Ganti nama “Layer 1” menjadi “Background” 
Ganti nama “Layer 2” menjadi “Grafik” 
Ganti nama “Layer 3” menjadi “Script” 

 
  

4. Kunci layer Action dan Grafik dengan 
mengaktifkan icon gembok pada 2 layer 
tersebut 

5. Klik frame 1 layer Background 
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3. Membuat Objek (Background) 
1. Munculkan garis bantu gambar dengan cara : 

Klik kanan halaman → Rulers 
Klik kanan halaman → Grid → Edit Grid... 
Atur properties Grid seperti di bawah ini 

  
  

2. Membuat sumbu X (horisontal) 

Klik Line Tool (N)  → tahan tombol shift 
lalu buat garis lurus (horisontal) di stage. 

Klik Selection Tool (V)  → klik garis 
horisontal tersebut → atur ukuran menjadi 
W=550, H=0, X=0, Y=200 
 

 
 

 
  

3. Membuat sumbu Y (vertikal) 

Klik Line Tool (N)  → tahan tombol shift 
lalu buat garis vertikal pendek di stage. 

Klik Selection Tool (V)  → klik garis 
vertikal tersebut → atur ukuran menjadi 
W=550, H=0, X=0, Y=200 

 

 

  

4. Tampilkan nilai-nilai untuk sumbu horisontal (X) yaitu sudut-sudut kelipatan 90 yaitu 90, 180, 270 

dan 360. Klik Line Tool (N)  buatlah garis tanda nilai sudut sebanyak 4 buah dengan jarak 
antar tanda 90 pixel (9 kotak di garis bantu). 
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5. Klik Text Tool  → Font Type : Swis721 BT → lalu buat label pada garis horisontal dengan 
angka 0, 90, 180, 270, 360 dan X. 
 

 
  

6. Sumbu vertikal (Y) nilai yang digunakan adalah 
-50, -100, 50, 100 dan Y 
 
Klik Line Tool (N) → buat tanda nilai sudut 
sebanyak 4 buah dengan jarak antar garis 
adalah 50 pixel (5 kotak pada garis bantu) 
 

Klik Text Tool  → Font Type:Swiss721 BT 
→ buat label garis vertikal. 

 

7. Masih menggunakan Text Tool  → buat judul “Grafik Sinus y = 100 sin (x)” di bagian atas. 
8. Nonaktifkan kembali fungsi Rulers dan grid 

Klik kanan stage → Rulers 
Klik kanan stage → Grid → Show Grid... 
 

 
  

4. Membuat Objek (Grafik) 

1. Klik Selection Tool (V)  
Kunci (gembok) layer Background lalu 
buka (hilangkan) gembok layer Grafik 

2. Klik frame 1 layer Grafik 

 
  

3. Klik Oval Tool (O) 
stroke color = kosong 
fill color = biru 

 
→ buat lingkaran kecil di stage  
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4. Klik Selection Tool (V)  → klik lingkaran 
biru → atur ukuran menjadi W:5, H:5 

 
5. Klik kanan lingkaran biru → Convert to 

Symbol... 

   Name : grafik 
   Type : Movie Clip 

→ OK  
  

6. Klik lingkaran biru tadi → 
pada panel properties ganti <Instance Name> 
menjadi “grafik” (tanpa tanda petik) 

 
7. Kunci (gembok) layer Grafik 

 
  

5. Membuat Animasi Grafik dengan Script 
1. Buka gembok layer Script → klik frame 1 layer Script 
2. Klik menu Window → Actions (F9) → ketik syntax 

 

 
 

3. Test Movie (Ctrl + Enter) 
  

6. Simpan & Kerjakan Tugas 
1. Simpan (File → Save) di folder My 

Document\NPM-Nama Mahasiswa →  
file name : Grafik Sin → Save 

 
  

2. Tugas 
Lakukan lagi penyimpanan file (File → Save 
As...) di folder masing2 lalu simpan dengan 
nama “Grafik Cosinus” & sekali lagi simpan 
dengan nama “Grafik Tangen” 
 

Kemudian buat grafik untuk gelombang 
cosinus dan tangen masing-masing pada 
sebuah file yang berbeda. 
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Contoh file : 
My Documents/AsetFlash/Grafik Cosinus.swf My Documents/AsetFlash/Grafik Tangen.swf 

 

7. Penjelasan Script 
 

Untuk menghasilkan suatu nilai sinus, fungsi yang digunakan adalah fungsi sin, contoh cara 
penulisannya sebagai berikut : 

y = sin(90 o) 
Karena nilai yang dihitung oleh Flash berbentuk radian maka nilai sudut harus diubah ke 
nilai radian agar menghasilkan nilai yang sesuai (terkecuali jika memang nilai yang akan 
dihitung dalam bentuk radian) 
Rumus konversi sudut ke radian: 

Radian = sudut x π / 180o 
Untuk mendapatkan nilai π yang akurat dapat digunakan fungsi PI dari Math. Object. 
Sehingga rumus y = sin(90o) ditulis dalam Script menjadi:  

Y = Math.sin(90 * Math.PI / 180); 

 
Kordinat grafik (50,200) adalah kordinat awal dari 
gambar grafik yang akan dibuat  
 
Penjelasan Script halaman 37 adalah : 
Ketika nilai sudut kurang dari 361 (sudut < 361) maka 
proses perulangan dilakukan. 

1. Nilai sudut awal adalah 0 
2. a = 100 sin(0) = 0 
3. kordinat grafik di sumbu y = 200 –a = 200 – 0 = 

200 
4. Movie clip grafik dengan kordinat baru (50,200) 

diduplikasi menjadi movie clip baru 
3. dengan nama ”sinus” + sudut = “sinus0” dengan 

depth = 0. 
4. Kordinat x movie clip grafik dinaikan 1, sehingga 

grafik._x = 50 + 1 = 51. Kordinat 
5. baru movie grafik (51,200). 
6. Nilai sudut dinaikan 1, sehingga nilai sudut baru 

sudut = 1 
7. Proses diatas diulang sampai nilai sudut = 360 
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Sesi 6 : Animasi Lingkaran 
 

1. Pendahuluan 
Animasi lingkaran berasal dari sebuah lingkaran yang dipecah menjadi 4 bagian, tiap-tiap bagian 
mempunyai warna dan ukuran yang berbeda-beda. Selain itu tiap bagian tersebut juga dianimasikan 
dengan cara diputar pada sumbunya beberapa kali putaran. Background animasi menggunakan sebuah file 
Graphics Interchange Format (.GIF). Hasil akhir animasi adalah sebuah file video (.AVI). Sesi ini 
mengenalkan fitur untuk memutar objek pada sumbu yang sudah ditentukan baik itu CW-Clockwise (searah 
putaran jarum jam) atau CCW-Counter Clockwise (berbalik arah putaran jarum jam). 

 
2. Persiapan (Stage dan Lingkaran Dasar) 

1. Project baru flash (Ctrl + N) 
2. Klik menu Modify → Document (Ctrl + J) 
3. Atur ukuran bidang kerja 550 X 400 px → 

background hitam → Frame rate : 10 FPS → 
OK 

 
  

4. Klik Insert Layer 1x  
5. Ganti nama “Layer 2” menjadi “Lingkaran 1” 
6. Ganti nama “Layer 1” menjadi “Background” 

 
  

7. Klik frame 1 Layer “Lingkaran 1” 
8. Klik Oval Tool (O) → 

stroke color = (kosong) 
fill color = putih 

 
9. Tahan tombol SHIFT lalu buat lingkaran di 

canvas 
 
Tombol SHIFT digunakan agar objek yang 
diperbesar/diperkecil bisa simetris 
penambahan/pengurangan panjang & lebarnya.  
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10. Klik Selection Tool (V) → klik lingkaran putih 
11. Atur ukuran menjadi  

W:216, H:216, X:166, Y:91 

 

  

12. Klik tombol “Insert Layer”  → ganti nama 
layer baru tersebut manjadi “Lingkaran 2” 

13. Klik Oval Tool (O) → 
stroke color = kosong 
fill color = merah 

 
14. Tahan tombol SHIFT lalu buat lingkaran di 

stage 

 
  

15. Klik Selection Tool (V) → klik lingkaran merah 
16. Atur ukuran menjadi → 

W:190, H:190, X:180, Y:105 

 
 

17. Klik kanan lingkaran merah → Cut 

 
  

18. Klik frame 1 layer “Lingkaran 1” 

 
19. Klik menu Edit → Paste in Place (Ctrl + Shift + 

V) → tekan tombol “Esc” 

 
  

20. Klik lingkaran merah di stage → tekan tombol 
“Delete” 

 
 

21. Klik kanan layer “Lingkaran 2” → Delete Layer 
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22. Klik Line Tool (N)   
→ stroke color = merah muda (pink) 
 

23. Tahan tombol SHIFT lalu buat garis vertikal di 
samping kiri lingkaran putih  
 
garis harus lebih tinggi dari pada lingkaran dan jangan 
berada di atas lingkaran 

 
  

24. Tahan lagi tombol SHIFT lalu buat garis 
horisontal di atas lingkaran putih 

 
garis harus lebih panjang dari pada lingkaran dan 
jangan berada di atas lingkaran atau menempel pada 
garis vertikal pink 

 
  

25. Klik Selection Tool (V) → klik garis pink 
yang ada di kiri lingkaran (garis vertikal) 
 

26. Klik menu Window → Align (Ctrl + K) 
 

27. Pada jendela Align & Info & Transform, 
aktifkan menu “To Stage” → lalu klik Align 
Horisontal Center 
 

 

 

  

28. Lalu klik garis pink yang ada di atas lingkaran 
(garis horisontal) 
 

29. Pada jendela Align & Info & Transform, 
aktifkan menu “To Stage”  
→ lalu klik Align Vertical Center 
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30. Klik ¼ lingkaran yang ada di kiri-atas → ganti 
menjadi warna biru 

 
  

31. Klik ¼ lingkaran yang ada di kanan-atas → 
ganti menjadi warna hijau 

 
  

32. Klik ¼ lingkaran yang ada di kiri-bawah → 
ganti menjadi warna kuning 

 
  

33. Klik ¼ lingkaran yang ada di kanan-bawah → 
ganti menjadi warna merah 

 
  

 
 

 
34. Hilangkan garis pink lingkaran dengan cara : 

double klik garis pink (menyeleksi semua garis 
pink) → tekan “Delete” 
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3. 1 Lingkaran 4 Bagian 
 

1. Klik Selection Tool (V) → klik lingkaran biru 
→ atur ukuran W:109, H:109, X:166, Y:91 

  
  

2. klik lingkaran kuning → atur ukuran 
W:87.5, H: 87.5, X:187.4, Y:200 

 

 
  

3. Klik lingkaran hijau → atur ukuran  
W:51, H:51, X:275, Y:149.1 

  
  

4. Klik lingkaran merah → atur ukuran  
W:70.7, H:70.7, X:275, Y:200 

  
  

5. Klik kanan lingkaran biru → Convert to 
Symbol → Name: Biru → Type: Movie Clip 

 
  

6. Klik kanan lingkaran kuning → Convert to 
Symbol → Name: Kuning → Type: Movie Clip 

 
  

7. Klik kanan lingkaran hijau → Convert to 
Symbol → Name: Hijau → Type: Movie Clip 
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8. Klik kanan lingkaran merah → Convert to 
Symbol → Name: Merah → Type: Movie Clip 

 
  

9. Klik “Free Transform Tool (Q)”  → klik 
lingkaran Biru 

10. Geser titik pusat lingkaran biru ke pusat 
lingkaran 

 

 

  

11. Klik kanan lingkaran biru → Distribute to 
Layers 

 
  

12. Klik lingkaran kuning 
13. Geser titik pusat lingkaran kuning ke pusat 

lingkaran 

 
 

  

14. Klik kanan lingkaran kuning → Distribute to 
Layers 

 
  

15. Klik lingkaran merah 
16. Geser titik pusat lingkaran merah ke pusat 

lingkaran 

  
  

17. Klik kanan lingkaran merah → Distribute to 
Layers 

 
  

18. Klik lingkaran hijau 
19. Geser titik pusat lingkaran hijau ke pusat 

lingkaran 

  
  

20. Klik kanan lingkaran hijau → Distribute to 
Layers 
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21. Klik kanan layer “Lingkaran 1” → Delete Layer 

 
  

4. Menambah Efek Berpendar 

1. Klik Selection Tool (V)  
2. Klik lingkaran biru → masuk menu “Filters” 
3. Add Filter → Glow → Quality: High → Color: 

“Putih” 
 

  

4. Klik lingkaran kuning → masuk menu Filters  
5. Add Filter → Glow → Quality: High → Color: 

“Putih” 

 
  

6. Klik lingkaran hijau → masuk menu Filters 
7. Add Filter → Glow → Quality: High → Color: 

“Putih” 

 
  

8. Klik lingkaran merah → masuk menu Filters 
9. Add Filter → Glow → Quality: High → Color: 

“Putih” 

 
  

5. Animasi (Berputar Pada Titik Pusat) 
 

1. Klik Selection Tool (V)  
2. Klik layer Hijau 
3. Klik kanan frame 100 layer Hijau → Insert 

Keyframe 

 
  

4. Klik Frame 90 layer Hijau 
5. Pada panel “Properties” → ganti Tween : 

Motion → Rotate : CW → 40 times 
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6. Klik layer Merah 
7. Klik kanan frame 100 layer Merah → Insert 

Keyframe 

 
  

8. Klik Frame 90 layer Merah 
9. Pada panel “Properties” → ganti Tween : 

Motion → Rotate : CCW → 10 times 

 
  

 
10. Klik layer Kuning 
11. Klik kanan frame 100 layer Kuning → Insert 

Keyframe 

 
  

12. Klik Frame 90 Layer Kuning 
13. Pada panel “Properties” → ganti Tween : 

Motion → Rotate : CW → 10 Times 

 
  

 
14. Klik layer Biru 
15. Klik kanan frame 100 layer Biru → Insert 

Keyframe 

 
  

16. Klik Frame 90 Layer Biru 
17. Pada panel “Properties” → ganti Tween : 

Motion → Rotate : CW → 3 Times 

 
  

 
 

18. Klik Frame 1 Layer Background 
19. Klik File → Import → Import to Stage (Ctrl+R) 

→ masuk ke “My Document\Aset Flash” → 
pilih file “Background Animasi Lingkaran.GIF” 
→ Open 
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6. Publish (Export File Video – AVI) & Simpan 
1. Klik menu File → Export → Export Movie 

(Ctrl+Alt+Shift+S) 

 
  

Simpan di folder masing-masing 
2. Akses ke “My Documents\NPM-NAMA 

MAHASISWA” → File Name: Animasi 
Lingkaran → Save as type: Windows AVI 
(*.avi) → Save 

 
  

3. Jendela Export Windows AVI → 
Video format: 32 bit color w/alpha → OK  

  

4. Jendela Video Compression → Compression 
Quality: 100 → OK 

 
  

5. Simpan (File → Save) hasil modul ini ke folder  
(My Documents/NPM-NamaMahasiswa) → 
beri nama : Animasi Lingkaran → Save 

 
  

7. Tugas (Kerjakan di Lab) 
Selalu simpan di folder masing-masing 

1. Simpan ulang project pada modul ini (File → 
Save As) → akses ke “My Documents\NPM-
NamaMahasiswa” → beri nama : Animasi 
Lingkaran (tugas) → Save 

 
  

2. Tugas : tambahkan sebuah irisan lingkaran lalu putar pada pusat lingkaran, dengan kondisi : 

 Ukuran irisan bebas [ 
 

 
 
 

 
 
 

 
           ] 

 Bentuk bebas (boleh divariasi tapi bentuk dasarnya adalah irisan lingkaran) 
 Warna terserah,  arah putaran (CW/CCW), kecepatan putaran bebas (times) 
 + Efek (Glow/Bevel/Blur), parameter efek (size, quality, warna efek, dll) bebas 
 Letak irisan lingkaran berada di luar irisan lingkaran biru (tidak di dalam lingkaran utama) 
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Sesi 7 & 8 : Anton Series 
 

Materi dalam sesi ini merupakan pengembangan tutorial 
step-by-step dari buku “Draw and Animate with Flash” 

karya Diginnovac, Arry Maulana dan Karina Nasution terbitan 
Elex Media Komputindo tahun 2008. 

Hak cipta © berada pada penulis buku tersebut. 
Pengembangan terdapat pada penerapannya dalam sebuah studi kasus bukan pada 

pengembangan karakter atau objek-objek yang digunakan. 
 

 

1. Pendahuluan 
Demo pembuatan kartun sederhana 
akan dipaparkan pada sesi ini. Mulai 
dari pembuatan objek rumah, tong, 
latar pemandangan, hingga animasi 
berjalan karakter utama (Anton). Tiga 
tahap utama menggambar suatu objek 
yaitu (1)sketsa kasar, (2)sentuhan 
ulang bentuk dan (3)mewarnai. 
Pengenalan import file vektor (.WMF), 
membuat bentuk dinamis dan 
eksplorasi pewarnaan (panel Color 
Mixer dan Gradient Transfrom Tool) 
adalah fokus utama modul ini. 
Penggambaran objek-objek bersifat kondisional (tidak harus sama persis bentuk dan warnanya seperti pada modul). 

 

2. Persiapan 
Persiapan bidang kerja / Stage : 

1. Klik kanan stage yang berwarna putih → 
Document properties (Ctrl+J) 

2. Atur ukuran bidang kerja 1000 X 500 px → 
background putih → Frame rate : 10 FPS 

 
  

3. Klik menu View → Grid → Edit Grid... 
(Ctrl+Alt+G) 

4. Aktifkan Show grid → ganti panjang : 30 px 
→ lebar : 30 → OK 
 

Grid adalah garis bantu untuk menggambar. 

Untuk membuat garis pada step-step berikutnya selalu 

perhatikan garis bantu di yang ada di stage. Hal ini akan 

membantu Anda dalam menyesuaikan dengan instruksi 

yang ada di modul. 

 

  

5. Klik Properties timeline  → Short 
 
Mengaktifkan Short berarti memperkecil jarak antar 
layer. 
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6. Tambahkan 7 layer baru dengan cara : 
klik 7x Insert New Layer 

7. Double klik pada Layer Name untuk 
mengganti nama layer 

 
 

8. Beri nama masing-masing layer (berurutan 
dari atas) : 
Judul, Anton Icon, Anton Jalan-jalan, Awan, 
Rumah, Tong, Lubang, Pemandangan 

 

 
3. Membuat Objek (Rumah) 

 

1. Klik icon gembok dan ikon mata atas sendiri 
2. Lalu hilangkan tanda silang dan tanda gembok 

pada “layer Rumah” 
3. Klik frame 1 layer Rumah 

4. Klik Rectangle Tool  

→ Stroke Color : hitam 
→ Fill Color        : tanpa warna 

 
→ buat kotak di stage (ukuran bebas) 
 

 

  

5. Klik Selection Tool  → klik 2x pada kotak 
yang barusan dibuat 

6. Atur ukuran W:329, H:329, X:599, Y:61 

 
  

7. Klik Zoom Tool  → lalu zoom kotak di stage 
 
Kotak ini adalah bingkai dari rumah, jadi objek rumah 
hanya akan didirikan dalam area kotak ini. 
Kerangka rumah semuanya dibuat hanya menggunakan 
garis tepi (stroke color) tanpa ada warna pengisi (fill color) 
 

8. Klik Rectangle Tool  →  

→ Stroke Color : hitam 
→ Fill Color        : tanpa warna 

 
→ buat kotak kecil di dalam bingkai 

 

 

  

9. Klik Selection Tool  → klik 2x kotak kecil 
yang barusan dibuat → atur ukuran menjadi 
W:239, H:170, X:645, Y:213 
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10. Klik Line Tool (N)  

→ aktifkan Snap to Objek 
→ nonaktifkan Objek Drawing 

 
→ tahan SHIFT → buat atap kiri rumah 
→ tahan SHIFT → lalu buat yang kanan 

11. Ganti menjadi Selection Tool  → klik 2x 
atap yang barusan dibuat sehingga terseleksi 
atap kanan dan kirinya 

12. Edit → Copy 
13. Edit → Paste In Place 
14. Tekan keyboard arah panah 

bawah beberapa kali sampai atap 
ke-2 melewati dinding rumah. 

 

 

  

15. Klik Line Tool (N)  → tahan SHIFT → lalu 
buat garis untuk menutup atap rumah 

 
  

16. Klik Selection Tool  → lalu pilih/seleksi 
bagian-bagian yang tidak digunakan sebagai 
rumah → tekan delete/backspace untuk 
menghapusnya 

 

  

17. Klik Line Tool (N)  → tahan SHIFT → lalu 
tambahkan beberapa rangkaian garis untuk 
variasi atap (gambar samping) 

18. Klik Selection Tool  → seleksi bagian yang 
tidak digunakan → tekan delete 

 

 
  

19. Menambah ornamen Pintu Rumah 

Klik Line Tool (N)  → tahan SHIFT → lalu 
buat bentuk pintu (ukuran menyesuaikan) 
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20. Tekan keyboard Esc (untuk menghilangkan 
seleksi di semua objek) 

21. Klik Selection Tool  → sorotkan kursor ke 
bawah garis pintu atas hingga muncul 
lengkungan pada kursor mouse 

 
 → lalu klik & geser ke atas secukupnya  

  

22. Ulangi lagi pembuatan ornamen pintu untuk 
membentuk garis dalam (gambar samping) 

Line Tool  untuk membentuk rangka. 

Selection Tool  untuk melengkungkan. 
 

23. Klik Line Tool  → lalu tambahkan garis 
melintang di pintu bagian bawah 

 

 
  

24. Klik Selection Tool  → seleksi bagian yang 
tidak digunakan → tekan delete 

 
 

 

 
  

25. Membuat ornamen Jendela Rumah 

Klik 2x Rectangle Tool   → Corner radius : 
10 (melengkungkan sudut-sudut persegi) → OK 

 
 

→ Stroke color : hitam 
→ Fill color        : tanpa warna 

 
 

→ buat 2 kotak jendela di dekat pintu  
  

26. Klik Line Tool  → tahan tombol SHIFT → 
lalu tambahkan 2 garis variasi (+) di masing-
masing jendela 
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27. Membuat ornamen lubang angin 

Klik Oval Tool  

→ Stroke color : hitam 
→ Fill color        : tanpa warna 

 
→ tahan SHIFT → buat lubang angin di atas 
rumah (tarik secara diagonal dari kiri atas ke 
kanan bawah) 

 
  

28. Membuat ornamen papan rumah 

Klik Line Tool  → tahan SHIFT → buat 5 
garis melintang dari kiri ke kanan (lihat 
gambar) 

 
abaikan saja ketika pembuatan papan, garis akan 
menabrak pintu dan jendela. 

 
  

29. Klik Selection Tool  → pilih/seleksi bagian 
yang tidak digunakan → tekan delete 
 
Untuk menyeleksi lebih dari satu garis, sebelum memilih 
tahan terlebih dahulu tombol SHIFT 

 
 

30. Menambah ornamen cerobong asap 

Klik Line Tool  → buat cerobong asap di 
sebelah kiri atap 
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31. Mulai mewarnai rumah 
Buka file “Grafika Komputer D3.pdf” di desktop untuk 
tampilan yang lebih jelas (gambar, warna & teks) 

Klik Paint Bucket Tool (K)  → pilih warna 
merah → lalu klik pada papan-papan rumah 
untuk mulai mewarnainya 

 
 

Paint Bucket Tool hanya bisa digunakan untuk 
mewarnai isi dari bidang yang tertutup, tidak 
termasuk garis tepinya. 

 
32. Ganti warna Kuning → lalu warnai jendela 
33. Ganti warna Coklat → warnai Lubang Angin 

 
 

 
 

 

 
 

Untuk menjadikan warna menjadi warna tua/muda, 
gunakan Color Mixer yang ada di atas kanan. Contoh :  
(1) pilih warna dasar yang diinginkan  

 
(2) Pada Panel Color Mixer, geser keatas untuk 

menghasilkan warna muda, atau  
(3) Pada Panel Color Mixer, geser kebawah untuk 

menghasilkan warna tua 

 
 

 
  
34. Lalu warnai ornamen-ornamen yang lain : 

Pintu Luar 
Pintu Dalam 
Pintu Bawah 
Atap Depan 
Atap Bawah 
Cerobong Asap 

→ Coklat tua 
→ Coklat muda 
→ Orange 
→ Biru biasa 
→ Biru tua 
→ biru muda 

 
35. Objek rumah selesai dibuat. 

36. Klik Selection Tool  → klik 2x garis tepi 
rumah → tekan Delete 

37. Tutup dan kunci layer Rumah dengan cara 
mengklik pada 2 titik putih di layer Rumah. 
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2. Membuat Objek (Tong) 
 

1. Klik frame 1 layer Tong 
2. Hilangkan tanda silang dan tanda gembok di 

layer Tong 

 
 

3. Klik Rectangle Tool   
→ corner radius : 0  
→ OK 
 

→ Stroke Color : hitam 
→ Fill Color        : tanpa warna 

 
→ buat kotak di stage (ukuran bebas) 

4. Klik Selection Tool  → klik 2x kotak tersebut 
→ atur ukuran W:301, H:301, X:299, Y:89 

 
 

5. Klik Zoom Tool (Z)  → zoom kotak tersebut 

 
 

 

  
 

6. Klik Oval Tool (O)   

→ aktifkan Snap to Objek 
→ nonaktifkan Objek Drawing 

 

→ Stroke color : hitam 
→ Fill color        : tanpa warna 

 
→ tahan SHIFT 
→ buat lingkaran di dalam kotak 

 
  

7. Klik Selection Tool  → klik lingkaran 
tersebut 

8. Atur ukuran menjadi W:283, H:283, X:306, Y:97 

 
  

9. Tekan Ctrl+T  (memunculkan panel Transform)  
→ ubah jarak kanan-kiri menjadi 80% → tekan 
Enter 
 
Setelah badan tong terbentuk seperti gambar 
di bawah → kemudian tutup jedela Transform 
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10. Klik Oval Tool (O)  → buat bentuk elips 
(lonjong) seperti gambar di samping 

11. Klik Line Tool (N)  → lalu buat garis bawah 
Tong (gambar samping) 

12. Klik Selection Tool (V)  → seleksi/pilih 
bagian-bagian yang tidak digunakan → delete 

 
 

  

Jika pada saat menyeleksi, semua garis menjadi terseleksi 
seperti gambar samping,  
hal ini disebabkan posisi objek elip/garis yang dibuat itu 
tidak menempel pada garis (garis tidak saling tumpang 
tindih – garis tidak saling menempel). 
Untuk memperbaikinya → gunakan Zoom Tool (Z) , lalu di-
zoom bagian yang akan diperbaiki → klik Selection Tool 
(V), lalu klik garis yang tidak menempel, → klik Free 
Transform Tool (Q), tahan tombol Ctrl lalu atur ukurannya 
agar bisa saling menindih antar garis 

 
  

13. Lengkungkan garis bawah Tong 

 
  

14. Klik Line Tool  → buat 4 buah garis dari atas 
ke bawah di Tong 

15. Klik Selection Tool  → lengkungkan ke arah 
luar ke 4 garis yang barusan dibuat 
 

 
  

16. Klik Insert Layer  → ganti layer baru 
tersebut menjadi “Tong2” → klik frame 1 layer 
Tong2 

 
 

17. Klik Line Tool  → tahan SHIFT → buat 6 
garis melintang dari kiri ke kanan Tong 

18. Klik Selection Tool  → lengkungkan ke arah 
bawah ke 6 garis yang barusan dibuat, dimulai 
dari garis yang paling bawah 
 

19. Klik frame 1 layer Tong2 → Edit → Cut 
20. Klik frame 1 layer Tong → Edit → Paste in Place 
21. Tekan Esc → lalu seleksi/pilih garis-garis yang 

tidak diperlukan → delete 
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22. Kemudian lengkungkan 8 garis yang ada 
dipojok atas-bawah-kanan-kiri tong 
 
 

23. Klik Zoom Tool  → zoom area atas Tong 

 

 
  

24. Klik frame 1 Layer Tong2 → Klik oval tool  

→ Stroke color : hitam 
→ Fill color        : orange 

 
 

→ tahan SHIFT → buat lingkaran kecil di Tong 
bagian atas (gambar bawah) 
 

 
 

25. Klik selection Tool  → klik 2x lingkaran yang 
barusan dibuat → tahan tombol Ctrl → lalu 
geser ke beberapa tempat lain di Tong (lihat 
gambar samping) 
 
Menggeser objek sambil menahan tombol CTRL berguna 
untuk memindah dan menggandakaan suatu objek 

 
26. Klik frame 1 Layer Tong2 → Edit → Cut 
27. Klik frame 1 Layer Tong → Edit → Paste in 

Place 
 

28. Klik Line Tool  → lalu buat garis melintang 
di atas Tong 

 
 

29. Klik Selection Tool → lengkungkan ke atas  
garis atas Tong yang barusan dibuat 

 
 

 
 

 
 

 
 
 

 
 

 

30. Klik kanan layer Tong2 → Delete Layer 

 
31. Klik 2x garis tepi Tong → tekan Delete 
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32. Mulai mewarnai Tong 
Buka file “Grafika Komputer D3.pdf” di desktop untuk 
lebih jelas gambar, warna & teksnya 

Klik Paint Bucket Tool  → pilih warna 
Coklat → lalu pada panel Color Mixer, slider 
warna geser ke atas untuk menghasilkan warna 
coklat muda → klik bidang-bidang penyusun 
badan Tong 
 

 

   
  

 

33. Pada Color Mixer, geser ke bawah slider warna 
untuk menghasilkan warna coklat tua → lalu 
klik (warnai) garis vertikal Tong 
 

 
 

  

34. Ganti menjadi warna biru muda → klik variasi 
air di atas Tong 

 
  

35. Klik Selection Tool  → klik 2x garis tepi Tong 
→ Delete 

36. Klik kanan layer Tong2 → Delete Layer 
 
 
 
Objek Tong selesai dibuat → berikutnya 
mengatur tampilan Tong pada stage. 

 
  

37. Klik frame 1 layer Tong → Klik Modify → Group 
(Ctrl + G) 
 

Group (Ctrl + G) digunakan untuk mengelompokkan objek-
objek pada layer yang sama dalam satu kesatuan gambar. 

 

 

38. Klik objek Tong di stage → 
Atur ukuran menjadi W:54, H:54, X:541, Y:319 

 
 

39. Tahan tombol Ctrl → geser objek Tong ke 
kanan atas 
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40. Klik Tong ke-2 yang barusan dibuat → atur 
ukuran X:602, Y:312 

 
  

  

41. Klik objek Tong ke-2 → tahan Ctrl → lalu geser 
objek Tong ke-2 ke kanan 

 
  

42. Klik Free Transfrom Tool  → klik objek Tong 
ke-3 → lalu putar 900 ke kiri (gambar samping) 
 

 

 
  

43. Klik Selection Tool  → klik objek Tong ke-3  
→ atur ukuran menjadi X : 864, Y : 317 

 
  

3. Mebuat Objek (Anton Series) 
 

1. Membuat kepala Anton 
→ Kunci semua layer kemudian tampilkan 
hanya layer Anton Icon 
 

→ Klik Oval Tool  

→ Stroke color : hitam 
→ Fill color        : tanpa warna 

 
→ tahan Shift → buat lingkaran di stage 

→ klik selection Tool (V)  → klik lingkaran 
yang barusan dibuat → atur ukuran menjadi 
 

 
 

→ klik Zoom Tool (Z)  → lalu zoom 
lingkaran tersebut 
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2. Klik Line Tool  → aktifkan Snap to Objek 

  → ketebalan : 1, warna : hitam 

 
 

→ kemudian buat bentuk wajah Anton 
 

Pastikan setiap segmen garis saling menimpa. 
 

  

3. Klik Selection Tool  → seleksi (klik) bagian 
lingkaran yang berada di bawah rangkaian 
garis → tekan delete 
 
Seleksi garisnya satu per satu kemudian tekan “Delete”, 
lalu pindah ke garis berikutnya 

 
  

4. Klik Oval Tool   

→ Stroke color : hitam 
→ Fill color        : tanpa warna 

 
tahan tombol Shift → buat 2 lingkaran di 
sebelah kanan kiri wajah (membuat telinga) 

5. Klik Selection Tool  → seleksi (klik) bagian 
lingkaran telinga yang ada di wajah → Delete  

  

6. Klik Line Tool (N)  → kemudian buat garis 
variasi rambut 

7. Klik Selection Tool (V)  → seleksi (klik) 
bagian lingkaran yang ada di bawah variasi 
rambut → Delete 

 
  

8. Kemudian lekukkan segmen-segmen garis yang 
membentuk variasi rambut (agar tidak kaku) 

 
Untuk melekukkan rambut jangan klik 
pada garis, tapi arahkan kursor ke garis-
garis pembentuk rambut sehingga 
muncul tanda setengah lingkaran di 
kursor → baru kemudian digeser untuk 
melengkungkan sesuai keinginan 

 
 

 
  

9. Selanjutnya tambahkan variasi perwajahan, 

mata menggunakan lingkaran  

hidung dan mulut menggunakan garis  
 
khusus pembuatan bola mata, Fill Color diisi warna hitam. 
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10. Menggambar badan Anton 

Klik Line Tool (N)  → aktifkan Snap to Objek 

  → ketebalan : 1, warna : hitam 
 

 
 

→ kemudian buat bentuk badan Anton 
(gambar samping) 
 
Gunakan garis bantu-garis bantu yang ada sebagai 
panduan pembuatan badan Anton. 

 
  

11. Klik Selection Tool  → lalu lengkungkan 
garis-garis pembentuk badan Anton 

 
  

12. Menggambar tangan kanan Anton 

Buat gambar tangan kanan menggunakan Line Tool (N)  → klik Selection Tool (V)  → lalu 
lengkungkan garis tangan yang ada di luar 
 

   

 

13. Menggambar tangan kiri Anton  

Buat gambar tangan kiri menggunakan Line Tool (N)   → klik Selection Tool (V)  → 
lengkungkan garis tangan yang ada di luar 
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14. Menggambar celana Anton 

Masih menggunakan Line Tool  → buat garis 
celana Anton 
 
 
Untuk menghapus bagian yang salah/tidak digunakan, 
bisa juga menggunakan Eraser Tool (E). 

 
  

15. Klik Selection Tool  → lalu lengkungkan 
garis celana bagian bawah 

 
  

16. Menggambar kaki dan sepatu Anton 

Klik Line Tool  → buat garis yang 
membentuk kaki dan sepatu Anton 

 
  

17. Klik Selection Tool  → klik frame 1 layer 
Anton Icon → Modify → Group 
 

18. Tekan Ctrl + 2 (center canvas) 
→ kemudian klik gambar Anton di Stage  
→ atur ukuran menjadi W:56, H:106, X:857, Y:7 
 

 

 
  

19. Membuat objek Judul 
Kunci layer “Anton Icon” → kemudian buka 
hanya Layer Judul 

 
 

20. Klik frame 1 Layer Judul 

Klik Text Tool  → Font : Mandela → Size : 25  
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21. Klik di sebelah kanan gambar Anton → 
kemudian buat text “Anton Series” 
 
Teks “Anton Series” dibuat pindah baris. 

 
 

22. Klik Selection Tool  → klik text “Anton 
Series” → atur text sesuai dengan posisi 
gambar samping. 
 
Gunakan arah panah keyboard untuk memindahkan lebih 
presisi (menggeser per 1 pixel). 
 

 
  

23. Klik teks “Anton Series” → masuk tab Filter 
→ tambahkan efek Glow (berpendar) → 
ukuran : 2 → kekuatan pendar : 450% → 
Quality : High → Warna : hitam 

 
 

3. Mebuat Objek (Anton Jalan-jalan) 
 

1. Klik frame 1 layer Anton Jalan-jalan  
→ buka editing layer Anton Jalan-jalan 
 

 
 

2. Klik File → Import → Import to Library... 
akses My Documents/Aset Flash/Modul 3 & 4 
→ kemudian blok (seleksi) file “AJ frame 
1.wmf” sampai dengan “AJ frame 8.wmf” → 
Open  

  

3. Tekan Ctrl + L (membuka panel Library) → cari 
file “AJ Frame 1.wmf” → lalu geser “AJ Frame 
1.wmf” ke stage (drag & drop) 

 
  

4. Tekan Ctrl + 2 (center canvas) → 
klik gambar Anton yang barusan di drag → 
atur ukuran menjadi  
W:77, H:127, X:-34, Y:331 
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5. Klik kanan gambar Anton yang ada di pojok → 
Convert to Symbol → Name : Jalan-jalan → 
Type : Movie Clip → OK 

 
 

  

6. Double klik pada gambar Anton jalan-jalan  
(masuk editing 
movie clip Anton 
Jalan-jalan)  

 

 

7. Klik Zoom Tool (Z)  → zoom objek Anton 
jalan-jalan 

 

  

8. Ganti nama “Layer 1” menjadi “Anton” 
 

 
 

9. Blok (seleksi) dari frame 1 sampai frame 8 
Layer Anton → klik kanan pada area terseleksi 
→ Convert to Keyframe  

  

10. Klik Selection Tool  → klik frame 2 layer 
Anton → klik kanan gambar Anton Jalan2 → 
Swap Symbol... → pilih “AJ frame 2.wmf” → 
OK 
 
Swap symbol berguna untuk menukar antara objek-objek 
yang sejenis (mempunyai jenis file sama)  

  

11. Klik frame 3 layer Anton → klik kanan gambar 
Anton Jalan2 → Swap Symbol... → pilih “AJ 
frame 3.wmf” → OK 

 
  

12. Klik frame 4 layer Anton → klik kanan gambar 
Anton Jalan2 → Swap Symbol... → pilih “AJ 
frame 4.wmf” → OK 

 
  

13. Klik frame 5 layer Anton → klik kanan gambar 
Anton Jalan2 → Swap Symbol... → pilih “AJ 
frame 5.wmf” → OK 
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14. Klik frame 6 layer Anton → Klik kanan gambar 
Anton Jalan2 → Swap Symbol... → pilih “AJ 
frame 6.wmf” → OK 

 
  

15. Klik frame 7 layer Anton → klik kanan gambar 
Anton Jalan2 → Swap Symbol... → pilih “AJ 
frame 7.wmf” → OK 

 
  

16. Klik frame 8 layer Anton → klik kanan gambar 
Anton Jalan2 → Swap Symbol... → pilih “AJ 
frame 8.wmf” → OK 

 
  

17. Klik Scene 1 yang ada di Timeline atau tekan 
Ctrl + E (kembali ke scene utama) 

 
  

 
3. Membuat Objek (Latar Pemandangan) 
 

 
1. Klik frame 1 Layer Pemandangan → 

tutup dan kunci semua layer kecuali milik 
layer pemandangan dengan cara  

 
2. Tekan Ctrl + 2 (center canvas) 
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3. Klik Rectangle Tool 

→ Stroke color : hitam 
→ Fill color        : tanpa warna 

 
→ buat kotak di stage (ukuran bebas) 

4. Klik Selection Tool  → klik 2x kotak yang 
barusan dibuat 

 
  

5. Tekan Ctrl + K (membuka menu Align) 
→ Aktifkan To Stage  
→ klik Center Vertikal 
→ klik Center Horisontal 
→ klik Match Width and High 
 
 
Menu Align digunakan untuk menyamakan kedudukan 
suatu objek pada stage (baik ukuran maupun koordinat), 
“Match Width and High” menyamakan suatu objek 
dengan ukuran panjang & lebar stage. 

 
  

6. Klik Line Tool  → kemudian  buat garis 
rangkaian perbukitan (lihat gambar samping 
step by step) 
 
→ buat bentuk dasarnya dari satu garis yang melintang 
dari kiri kekanan stage (gambar ①)  
 
→ kemudian buat lagi garis miring untuk membentuk 
garis bukit (gambar ②) 
 
→ kemudian lengkungkan dengan Selection Tool (V) 
 
→ klik Line Tool (N) → bentuk lagi garis bukit ke-2 
(gambar ③)  
 
→ klik Selection Tool (V) → kemudian lengkungkan  
 
→  klik Line Tool (N) → bentuk garis ke-3 (gambar ④)  
 
→ klik Selection Tool (V) → lengkungkan 
 
 
 
Hasil Akhir bukit di stage 

 

 
 

 

 
 

 

 
 

 

 
 

 

 
 
 

 

 

  

7. Klik Paint Bucket Tool (K)  → pilih warna 

hijau  → warnai (klik) bukit sebelah 
kiri 
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8. Geser slider warna hijau ke atas di Color Mixer 
→ warnai bukit yang di tengah 

 

 

  

9. Geser slider warna hijau ke bawah di Color 
Mixer → warnai bukit yang di sebelah kanan 

 

 

  

10. Tekan Esc untuk menghilangkan seleksi 
11. Ganti warna menjadi gradasi biru ke hitam 

 
 
→ pada Color Mixer klik 2x palet hitam 
→ ganti menjadi putih 
→ Type : Linier  
 

  
  

12. Lalu warnai gambar langit di stage 
 

13. Perkecil tampilan stage Flash menjadi 25% 
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14. Klik Free Transform Tool  → klik gambar 
langit di stage → lalu pindahkan warna 
gradasinya. 
 
Letakkan kursor di ujung 
gambar seperti ini lalu 
geser ke bawah 

 
  

15. Perkecil ukuran gradasinya dengan cara 
menggeser handle ke atas 

 
  

16. Tekan Esc (menghilangkan seleksi) 
Ganti warna Paint Bucket Tool dengan warna 
gradasi linier putih-hitam 

 
 
→ pada Color Mixer, ganti warna hitam di 
pojok kanan dengan warna coklat 

 
 

→ Klik kotak area tanah di stage  
  

17. Klik Free Transform Tool  → klik gambar 
tanah di stage → lalu pindahkan warna 
gradasinya. 

 
Letakkan kursor di ujung 
gambar seperti ini lalu 
geser ke bawah 

 
 

  

18. Perkecil ukuran gradasi tanah  
 

19. Kunci (gembok) Layer Pemandangan 
 

Hasil Akhir Pemandangan
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3. Membuat Objek (Awan) 
 

1. Klik Selection Tool  
2. Klik frame 1 layer Awan 

→ buka menu editing layer Awan 

 
 
3. Klik File → Import → Import to Stage (Ctrl + R) 

akses My Documents /Aset Flash/Modul 3 & 4 
→ Awan.swf → Open 

 
 

3. Membuat Objek (Lubang) 
 

1. Klik frame 1 Layer Lubang  
2. Kunci (gembok) semua layer kecuali layer 

Lubang 
 

3. Tutup semua layer kecuali layer Pemandangan 
dan layer Lubang 
 

4. Klik Oval Tool (O)  

→ Stroke color : tanpa warna 
→ Fill color        : coklat tua 

  

 
  

5. Buat 3 bentuk lonjong di 
sekitar pemandangan (area 
tanah) 

 

6. Klik 2x icon mata paling atas  untuk menampilkan semua objek layer di stage 
7. Klik icon gembok paling atas untuk mengunci semua layer 
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4. Membuat Animasi 
 

1. Klik frame 1 layer Anton Jalan-jalan 
→ tampilkan layer dan hilangkan gembok 
Layer Anton Jalan-jalan 
 

 
 
 

2. Klik kanan frame 120 Layer Anton Jalan-
jalan → Insert Keyframe 

3. Tahan tombol Shift → lalu geser objek 
Anton ke kanan stage (lihat gambar) 
 
buat agar objek Anton setengah berada di luar 
stage dan setengahnya lagi di dalam stage 

  
  

 
4. Klik kanan frame 1 layer Anton Jalan-jalan → 

Create motion Tween 

 
  

 
5. Klik kanan frame 120 Layer Anton Jalan-jalan 

→ Create motion Tween 

 
  

 
6. Klik kanan frame 120 layer Judul → Insert 

Frame 
 

7. Klik kanan frame 120 layer Anton Icon → 
Insert Frame  

  

8. Klik frame 120 Layer Rumah → tahan tombol 
Shift → klik frame 120 layer Pemandangan → 
klik kanan pada area terseleksi → Insert Frame 

 
  

9. Hasil 
akhir 
tampilan 
Timeline. 

 
 
 

Beres.  
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5. Simpan 
Pembuatan multimedia linier dalam bentuk kartun “Anton Series” selesai dibuat, tekan Ctrl + Enter atau 
klik Control → Test Movie untuk melihat hasilnya. Klik File → Save As... (Ctrl + Shift + S) → simpan hasilnya 
di folder masing-masing My Documents/NPM-NamaMahasiswa dengan nama file “Anton Series”. 

 

 
 

6. Tugas (Kerjakan di lab) 
Sebelum mulai mengerjakan simpan ulang project sesi ini (File → Save As) dengan nama “Anton Series 
Modif” di folder masing-masing (My Documents/NPM-NamaMahasiswa) → Save 
 

 
 
Tugas : modifikasi animasi yang sudah dibuat pada modul ini, contoh mengganti warna, menambah 
karakter hewan/manusia, menambahkan animasi pada karakter Anton, menambahkan jumlah awan, dsb. 
Tidak ada aturan tertentu dalam memodifikasi, berkreasilah-ubahlah-editlah sekreatif mungkin. 
Jumlah modifikasi/penambahan minimal ada 2 objek yang dirubah/ditambahkan di animasi ini. 
 

 
 
 

Contoh file ada di My Documents/Aset Flash/Anton Series Modif.swf 
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